Seneste forumindlæg
Køb / Salg
 * Uofficiel Black/White liste V2
Login / opret bruger

Forum \ Off Topic \ Anden computer snak

KVM - Windows køre langsom

Af Semi Nørd dgaa1991 | 15-07-2019 22:53 | 776 visninger | 16 svar, hop til seneste
Hej Hol. Jeg er efterhånden blevet træt af dualboot og tænkte det ville være forsøget værd at køre det i en virtuel maskine. Mit eneste problem er at den virtuelle maskine med Windows 10 Pro køre en anelse langsom. HDD, NIC samt Video køre alle 3 med VirtiO driverne men input fra mus og tastatur er der et lille delay på hvilket er temmelig træls, ellers virker det ganske fornuftigt. Jeg mistænker at der er grafikkortet der er skyld i dette og når jeg køre Windows WEI får jeg også kun 2, 2-1 point ved grafikkortet? Nogle gode ideér eller forslag her? Det er nok relevant at få med at jeg forbinder til den virtuelle maskine med virt-manager
--
Sidst redigeret 15-07-2019 22:54
#1
inckie
Elite Nørd
16-07-2019 08:43

Rapporter til Admin
Gætter på du bruger QXL/SPICE - det har den dårligste performance Men hvilken display metode bruger du ? Eneste grund til at bruge QEMU, tænker jeg er fordi man ønsker at passthrough PCI devices, som f.eks. et grafikkort. Ellers brug Virtualbox - jeg vil gætte på det er lidt nemmere at få god grafisk performance, med 2D/3D acceleration enabled.
--
https://twitter.com[...] - Ned med #lurerSørenPape https://linuxmint.com[...] - Få dit privatliv tilbage.
#2
dgaa1991
Semi Nørd
16-07-2019 11:49

Rapporter til Admin
#1 jeg er ret ikke ved min PC lige nu, men jeg bruger qxl med 3D acc. Slået til. Grunden til jeg bruger KVM/QEMU er at der skulle være en del performance at hente, jeg kan dog ikke lave GPU passthrough på min Dell XPS 9550 mig bekendt.
--
#3
inckie
Elite Nørd
16-07-2019 12:40

Rapporter til Admin
#2 Grunden til jeg bruger KVM/QEMU er at der skulle være en del performance at hente I forhold til hvad ?
--
https://twitter.com[...] - Ned med #lurerSørenPape https://linuxmint.com[...] - Få dit privatliv tilbage.
--
Sidst redigeret 16-07-2019 12:40
#4
dgaa1991
Semi Nørd
16-07-2019 15:34

Rapporter til Admin
#3 den generelle performance, men jeg kunne være gal på den her! https://www.phoronix.com[...]
--
#5
inckie
Elite Nørd
16-07-2019 16:43

Rapporter til Admin
#4 Jeg tænkte mere på QXL/Spice (QEMU) vs VMSVGA (Virtualbox) - har du husket af installere QXL windows driver / spice guest agent og har du gjort noget for at optimere indstillinger (e.g. justering af VRAM) ? Du kan også prøve at passthrough dit mus/keyboard (USB) og se om det gør en forskel (du kan evt. også tilslutte et ekstra sæt til din computer) - VM'en skulle gerne "give slip" når du slukker den. Alternativt skal du lege med virtio-gpu, men jeg tror ikke rigtig det virker under Windows: https://gitlab.freedesktop.org[...] - jeg kan kun finde kildekoden, ingen Windows builds. Sidst men ikke mindst, så tror jeg din CPU understøtter vGPUs: https://www.reddit.com[...]
--
https://twitter.com[...] - Ned med #lurerSørenPape https://linuxmint.com[...] - Få dit privatliv tilbage.
--
Sidst redigeret 16-07-2019 16:46
#6
dgaa1991
Semi Nørd
16-07-2019 19:47

Rapporter til Admin
#5 Det er faktisk et godt spørgsmål, med Virtualbox havde jeg en del artifacts og grafik problemer hvlket var grunden til jeg følte mig nødsaget til at prøvet noget andet. Jeg har lige installeret spice guest tool, og givet den 32M ram istedet for 16M hvilket har gjort underværker. Dog syntes jeg stadig at maskinenn køre lidt langsom og CPU maxer ofte 100% ud når man kigger i joblisten. Jeg tænker ikke at jeg har lyst til at lave USB passthrough da jeg kun bruger windows installationen til Visual Studio 2019 og ellers bruger jeg Linux til alt andet. Angående vGPUs må jeg lige prøve at kigge på det, det ser temmelig neat ud.
--
#7
inckie
Elite Nørd
16-07-2019 20:42

Rapporter til Admin
#6 Her er nogle flere spørgsmål: 1. Bruger du RAW image, QCOW2 image eller en partition som storage device og hvad er cache type sat til ? 2. Har du VirtIO balloon driver installeret ? - hvis ja, så fjern den. Den kan skabe performance problemer - og du lever nok fint uden muligheden for at justere guest memory mens den kører.
--
https://twitter.com[...] - Ned med #lurerSørenPape https://linuxmint.com[...] - Få dit privatliv tilbage.
--
Sidst redigeret 16-07-2019 20:43
#8
dgaa1991
Semi Nørd
16-07-2019 20:49

Rapporter til Admin
#7 1. Jeg bruger RAW image for at få den beste mulige performance. Jeg har også slet alle visuelle effekter fra inden i windows for at få den bedste performance. 2. Jeg tror der var en del af spice guest tool så må lige se om jeg ikke kan få den fjernet Og tusinde tak for hjælpen so far!
--
Sidst redigeret 16-07-2019 20:49
#9
inckie
Elite Nørd
16-07-2019 20:56

Rapporter til Admin
Hvad med cache ? her er et snippet af min disk opsætning: https://pastebin.com[...] Jeg bruger 2x partitioner på en SSD (C: og D:), til min VM. Det giver i øvrigt en mulighed for at justere størrelse, tage backups m.m. via "disks" værktøjet.
--
https://twitter.com[...] https://linuxmint.com[...] - Få dit privatliv tilbage.
--
Sidst redigeret 16-07-2019 21:02
#10
dgaa1991
Semi Nørd
16-07-2019 21:22

Rapporter til Admin
#9 Cache er sat til writeback, mens vi er ved det, hvad er din Video sat til?
--
#11
inckie
Elite Nørd
16-07-2019 21:45

Rapporter til Admin
#10 Prøv at leg med de forskellige cache typer: https://doc.opensuse.org[...] Jeg har ikke noget paravirtualiseret video device, jeg bruger et Nvidia kort via PCI passthrough
--
https://twitter.com[...] https://linuxmint.com[...] - Få dit privatliv tilbage.
--
Sidst redigeret 16-07-2019 21:49
#12
jalling
Bruger
17-07-2019 07:38

Rapporter til Admin
Hvor mange vCPU'er har du tildelt din VM? Jeg har et tilsvarende scenarie på min arbejds PC, hvor jeg af og til er nødt til at benytte nogle Windows programmer, og det hjalp betydeligt da VM'en fik mere end en enkelt vCPU at gøre godt med - måske det kan hjælpe. Mvh Jonas
--
#13
jalling
Bruger
17-07-2019 08:01

Rapporter til Admin
#12 tillæg.. Det skal lige siges at jeg kører VirtualBox på min arbejdscomputer. Mvh Jonas
--
#14
dgaa1991
Semi Nørd
17-07-2019 12:33

Rapporter til Admin
#12 jeg har en intel i7 med HT of har givet den 4 cors of 8 GB ram
--
#15
jalling
Bruger
17-07-2019 12:37

Rapporter til Admin
#14 ok, det er nøjagtig hvad jeg har givet min VM - well, det var et forsøg værd :) Mvh Jonas
--
#16
dgaa1991
Semi Nørd
17-07-2019 14:48

Rapporter til Admin
Men det køre i og for sig også godt nok efter hånden ;) Tusinde tak for hjælpen so far!
--

Opret svar til indlægget: KVM - Windows køre langsom

Grundet øget spam aktivitet fra udlandet, er det desværre ikke muligt for dig, at oprette svar som gæst.

Hvis du ønsker at deltage i debatten, skal du oprette en brugerprofil.

Opret bruger | Login
NYHEDSBREV
Afstemning