Seneste forumindlæg
Køb / Salg
 * Uofficiel Black/White liste V3
Login / opret bruger

Forum \ Programmering og webdesign \ Hjemmeside design

Hjemmeside nede - PHP 7.4 -> PHP 8.0

Af Mega Supporter Lommelygte | 28-11-2022 13:34 | 638 visninger | 8 svar, hop til seneste
Hej HOL Vi hoster vores website via one.com og bruger WordPress. De har pr. dags dato udfaset PHP 7.4, hvorfor vi er nødt til at opgradere til PHP 8.0. Vores hjemmeside er nede grundet dette - og da vores mediegrafiker er indisponibel, sidder jeg nu med tjansen - og har ingen erfaring herfor. INGEN. Jeg har så alligevel prøvet mig lidt frem, da chefen, som heller ingen erfaring herfor mente, at det må være nemt via diverse vejledninger/chatrobotten på one.com - så jeg behøver da ikke bruge penge på en udvikler. Nå, fedt ;-) Jeg prøvede i fredags at opdatere til PHP 8.0, men fik følgende error efter de 20 minutters venten: "There has been a critical error on your website. Learn more about debugging in WordPress" Så kørte jeg debugging: "In this case, WordPress caught an error with your theme, Consultup PRO". Jeg har kontaktet dem, vi har købt/hentet temaet hos (ThemeAnsar)- men jeg forventer, at der kan gå en del tid, før de svarer. Som en total noob i dét her - er der så noget, jeg selv kan gøre? Ellers forestiller jeg mig, at der blot er 2 valgmuligheder: 1) Vent på dém vi har købt temaet af og afvent svar ift. om de kan gøre deres tema PHP 8.0 kompatibelt? 2) Find et andet tema? (Dette ønsker jeg helst ikke, men kan blive nødvendigt) Jeg håber, at der er en kyndig, der kan hjælpe mig med dette. Jeg sender sgu gerne lidt moneter på Mobilepay til en pizza fra den lokale :p
--
Lommelygte: +12/-0
#1
Gæsten
Gæst
28-11-2022 13:40

Rapporter til Admin
Slå temaet fra og se om din side overhovedet kan vises. Det vigtigste er vel også ikke er gå glip af salg. De her opdateringer er generelt noget du skal foretage dig på månedbasis.
--
Gæstebruger, opret dit eget login og få din egen signatur.
#2
Azakiel
Skribent
28-11-2022 13:50

Rapporter til Admin
Var temaet opdateret da One smed opdateringen ud? Det er nok noget der kan fikses. Hvis i slår debugging til (og PHP error output, eller læser error loggen) så burde i kunne se hvad den konkrete fejl er, og så løse det her fra.
--
Veni, Vidi, Vici. dimidium facti qui coepit habet faber est quisque fortunae suae
#3
Lommelygte
Mega Supporter
28-11-2022 13:54

Rapporter til Admin
#1 Yes, så virker hjemmesiden i det mindste - men så får jeg følgende fejlmeddelse: Warning: Constant DISALLOW_FILE_EDIT already defined in /customers/5/9/0/XXX.com/httpd.www/wp-config.php on line 120 Warning: Cannot modify header information - headers already sent by (output started at /customers/5/9/0XXX.com/httpd.www-config.php:120 in/customers/5/9/0XXX.com/httpd.www./wp-content/plugions/onecom-vcache/vcaching.php on line 306 (XXX indsat i stedet for firmanavn)
--
Lommelygte: +12/-0
#4
Lommelygte
Mega Supporter
28-11-2022 13:57

Rapporter til Admin
#2 Puha, det er et godt spørgsmål. Det tror jeg ikke, at det var? Temaet har været anvendt i 1,5 år og jeg mener ikke, at vores mediegrafiker har pillet ved det siden. Debugging og PHP-fejlmeddelser er slået til, og giver beskeden ovenfor
--
Lommelygte: +12/-0
#5
Azakiel
Skribent
28-11-2022 13:58

Rapporter til Admin
#3 Det er nok fordi wp_debug eller PHP errors er sat til at spytte ting ud, warnings er ikke kritiske (endnu) for sidens brug så det kan slås fra. #4 Har i tjekket om der var en ventende opdatering? Ellers kan det nok give god mening selv at tilpasse temaet, hvis forventningen er at der ikke kommer en senere opdatering til temaet, som kan komme til at overskrive evt. ændringer i måtte lave i det.
--
Veni, Vidi, Vici. dimidium facti qui coepit habet faber est quisque fortunae suae
--
Sidst redigeret 28-11-2022 13:58
#6
holmvard
Ny på siden
28-11-2022 15:35

Rapporter til Admin
I er også altid velkomne hos os på Simply.com - vi giver vores kunder mulighed for at vælge PHP version selv. Se evt. https://blog.simply.com[...] Hvis I ønsker assistance til flytning, kan vi også tilbyde hjælp til den del. Tag endelig kontakt på simply.com/support så vender vi straks tilbage. MVH Tim, Support Manager - Simply.com
--
#7
Lommelygte
Mega Supporter
28-11-2022 15:51

Rapporter til Admin
Tak for jeres svar. Jeg fik lov til at bruge lidt penge på en udvikler, som er i gang med at fixe det. Kan lige opdatere tråden, når jeg ved mere / når den forhåbentlig er oppe at køre igen ;-)
--
Lommelygte: +12/-0
#8
Sheepass
Mega Supporter
06-12-2022 23:02

Rapporter til Admin
Tror bare jeg ville lave en kopi og flytte sitet til en host, der ikke dikterer hvilken version af php I bruger. chosting har Cpanel og der kan du selv bestemme versionen, det samme er tilfældet ved f.eks Azehosting. one.com er alligevel pisse ringe og mega langsom hosting i DK
--
Flødedyr med hang til RAM

Opret svar til indlægget: Hjemmeside nede - PHP 7.4 -> PHP 8.0

Grundet øget spam aktivitet fra udlandet, er det desværre ikke muligt for dig, at oprette svar som gæst.

Hvis du ønsker at deltage i debatten, skal du oprette en brugerprofil.

Opret bruger | Login
NYHEDSBREV
Afstemning


ANNONCE