Seneste forumindlæg
Køb / Salg
 * Uofficiel Black/White liste V2
Login / opret bruger

Forum \ Off Topic \ Hyggekrogen

Excel spørgsmål - formel

Af Gæst kauw | 07-07-2020 15:15 | 398 visninger | 8 svar, hop til seneste
Hej HOL Jeg har et Excel spørgsmål, som jeg håber, at nogle af jer kan svare mig på. :) I kolonne O skriver jeg - afhængig af min registrering - eksempelvis 100/5, 200/5, 300/5 osv. Bare indsat som tekst. Kan jeg så godt i kolonne P (den næste kolonne) lave et regnestykke, som selv tager tallet der står i kolonne O og regner om? Altså hvis der eksempelvis står 100/5 i kolonne O, så skriver den 20, eller hvis der står 200/5 i kolonne O, så skriver den 40, osv. På forhånd tak!
--
Gæstebruger, opret dit eget login og få din egen signatur.
#1
kreutzer
Monsterbruger
07-07-2020 15:21

Rapporter til Admin
Jeg ved ikke om der findes en smartere måde, men hvis du altid bruger tre tal og dividerer med ét tal, så kan du bruge denne formel: =SUM(LEFT(M15;3)/(RIGHT(M15;1))) Erstat selvfølgelig M15 med den celle data står i.
--
Signatur (valgfri)
#2
ChristianL
Monster Supporter
07-07-2020 15:23

Rapporter til Admin
Hvis du vender den om, er det måske nemmere. A1: "=1000/50" (eller bare +1000/50, hvilket er lidt hurtigere på numpad) A2: "=formeltekst(A1) A1 viser så 20 A2 viser så "=1000/50" Hvis A2 ikke skal vise "=", så kan du i A2 skrive: =MIDT(A1;2;99) Den tager så karaktererne på plads 2 til 99 og printer i cellen - i det her tilfælde: A2 viser så "1000/50" Giver det mening? EDIT: Med udgangspunkt i #1 kan man også lave en formel, der splitter tallene ved "/", men den er lidt længere, den kan jeg sgu ikke lige i hovedet
--

--
Sidst redigeret 07-07-2020 15:25
#3
kauw
Gæst
07-07-2020 15:28

Rapporter til Admin
#1 Tak, det fungere med de 3 tal jeg har nævnt, men nogle gange registrerer jeg også eksempelvis 1000/5 eller 1500/5 osv. Så det er ikke altid de samme tal der går igen. :) #2 Nej ikke helt, sidder lige og leger med det. Skal nok vende retur. :-D
--
Gæstebruger, opret dit eget login og få din egen signatur.
#4
ChristianL
Monster Supporter
07-07-2020 15:36

Rapporter til Admin
#3 Så er det den her: =VENSTRE(A1;FIND("/";A1)-1)/MIDT(A1;FIND("/";A1)+1;99) Hvor det sidste "99" indikerer længden af nævneren :)
--
#5
Winnick
Superbruger
07-07-2020 17:13

Rapporter til Admin
det kan gøres utrolig meget simplere hvis du vil 200 og 5 i hver sit felt? - skal de stå i det samme?
--
#6
kauw
Gæst
08-07-2020 08:41

Rapporter til Admin
#4 Tusind tak, det fungere præcis efter hensigten! :-) Jeg har faktisk et andet spørgsmål nu vi er i gang. Jeg har følgende formel: =HVIS(AB6=R6;("Ingen beregning");(R6/AB6)) Men når der ikke står noget i cellerne/når arket er tomt, skriver den #VÆRDI!. Kan jeg gøre sådan, at hvis der ikke står noget i cellerne AB6 og R6, så er cellen bare tom? Altså så der ikke står #VÆRDI!. OBS! Det samme sker i øvrigt med din formel #4. Der skriver den også #VÆRDI!, når der ikke står noget i A1 Tak igen. :)
--
Gæstebruger, opret dit eget login og få din egen signatur.
#7
ChristianL
Monster Supporter
08-07-2020 08:45

Rapporter til Admin
#6 Det kan du snildt gøre noget ved; du wrapper formlen i en "=HVIS.FEJL("FORMEL HER";"HVIS FEJL HER") Så fx =HVIS.FEJL(HVIS(AB6=R6;("Ingen beregning");(R6/AB6));"") Så giver den en blank celle i stedet for #VÆRDI :)
--
#8
kauw
Gæst
08-07-2020 08:58

Rapporter til Admin
#7 Tusind tak! :-)
--
Gæstebruger, opret dit eget login og få din egen signatur.

Opret svar til indlægget: Excel spørgsmål - formel

Grundet øget spam aktivitet fra udlandet, er det desværre ikke muligt for dig, at oprette svar som gæst.

Hvis du ønsker at deltage i debatten, skal du oprette en brugerprofil.

Opret bruger | Login
NYHEDSBREV
Afstemning